• お問い合わせ
  • ユーザー登録
ドキュメント
サポート案内
ユーザー登録
サポートセンター
ドキュメント
ダウンロード
セキュリティ
よくある質問とその回答
製品マニュアル
カタログ
収録パッケージ一覧


Tips No. 865

Maildir 対応の Dovecot 変更後に POP 受信ができなくなる


【現象】
Maildir 対応の Dovecot に移行した場合、メールを POP 受信できなくなる現象が
発生する可能性があります。
この場合、/var/log/maillog に以下のログが出力されます。

[/var/log/maillog]
------------------
May 29 14:57:25 tlas3 dovecot: pop3-login: Login: user=<ユーザ名>, method=PLAIN, rip=192.168.0.1, lip=192.168.10.10
May 29 14:57:25 tlas3 dovecot: POP3(taro): o_stream_send(/home/.sites/XX/siteX/.users/XX/ユーザ名/Maildir/dovecot-uidlist.tmp) failed: Disk quota exceeded
May 29 14:57:25 tlas3 dovecot: POP3(taro): Couldn't init INBOX: Internal error occurred. Refer to server log for more information. [2012-05-29 14:57:25]
May 29 14:57:25 tlas3 dovecot: POP3(taro): Mailbox init failed top=0/0, retr=0/0, del=0/0, size=0
------------------
※ホスト名、ユーザ名、ホームディレクトリ、IP アドレス等は環境に合わせて
  お読み替えください。

利用されているメールクライアントによっては、同様なエラーメッセージが表示される
場合もあります。

[クライアントが表示するエラーメッセージ]
----------------------------------------
-ERR Internal error occurred. Refer to server log for more information. [YYYY-MM-DD hh:mm:ss]
----------------------------------------


【原因】
POP 受信時に仮想サイトユーザに割り当てたディスク容量を超過していると、
dovecot-uidlist.tmp ファイルを作成できずに本現象が発生する場合があります。
※dovecot-uidlist.tmp は、クライアントがメールを既に受信したかどうかを
判断するために一時的に作成されるファイルです。

なお、本現象は TLAS3.0 / 4.0で Dovocot を利用する場合の制限事項となりますので、
あらかじめご了承ください。


【回避方法】
本現象が発生した場合には、以下の手順で回避してください。

回避手順1

1. Web 管理画面から admin ユーザでログインして当該ユーザの設定画面を開きます。

2. [アカウント設定] タブ -> [最大許容ディスク容量] を一時的に増やします。
   例) デフォルトの 20MB から 30MB に変更

3. メールクライアント側の [受信後もメールをサーバに残す] などの設定を無効に
   します(メール受信後はサーバからメール削除)。

4. POP 受信を行い、サーバに保存されているメールを削除します。

5. 手順 2. で変更した当該ユーザの [最大許容ディスク容量] を元に戻します。

上記を行っても改善しない場合は、手順 2. の後に当該ユーザ(自分自身)宛にテスト
メールなどを送信して dovecot-uidlist を更新させ、手順 3. 以降を行ってください。
その場合の手順は以下となります。


回避手順2

1. Web 管理画面から admin ユーザでログインして当該ユーザの設定画面を開きます。

2. [アカウント設定] タブ -> [最大許容ディスク容量] を一時的に増やします。

3. メールクライアント側の [受信後もメールをサーバに残す] などの設定を無効にします。

4. 当該ユーザ(自分自身)宛にテストメールなどを送信します。

5. POP 受信を行い、サーバに保存されているメールを削除します。

6. 手順 2. で変更した当該ユーザの [最大許容ディスク容量] を元に戻します。


【参考情報】
・Maildir
 http://www.dovecot.jp/wiki/Quota.FS.txt

・Control files
 http://wiki.dovecot.org/MailLocation/Maildir

上記の Dovecot サイトで解説されているように、本現象を回避するにはクォータで
容量制限を設けていないファイルシステムに dovecot-uidlist を作成しなければ
なりません。
しかし、TLAS3.0 / 4.0 は、クォータで仮想サイトユーザのファイルを管理する事を
前提としており、クォータの設定がされていないファイルシステムに仮想サイトユーザ
のファイルを作成するような修正を行う予定はありません。
そのため、本現象は、TLAS3.0 / 4.0 で Dovecot を利用する上での制限事項とさせて
頂きます。

キーワード
pop dovecot Maildir

関連文書
  • [841]IMAP / POP サーバーを Dovecot に変更し、Maildir 形式に移行するには

    対象製品
  • Turbolinux Appliance Server 4.0
  • Turbolinux Appliance Server 3.0
    Last modified : Mon Oct 19 JST 2015 # 2